HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» 1987 944 Turbo --> LS
Today at 8:38 pm by iamgod

» Oil Cooler Adapter Not Working?
Wed Oct 11, 2017 9:32 pm by sharkey

» 1987 944S 3800 L67 Turbo...in progress
Wed Oct 11, 2017 1:08 pm by Sirayden

» C6 Z06 Brakes on my 944
Wed Oct 11, 2017 8:25 am by Schuepbach

» sbc swap in a 1981 924
Mon Oct 09, 2017 9:28 pm by sharkey

» JP's LS1 Conversion
Mon Oct 09, 2017 8:42 pm by 924sbc406

» Cayenne Front and Rear Brakes on 944
Sun Oct 08, 2017 4:15 pm by superman22x

» Scca Xp solo build
Wed Oct 04, 2017 7:55 pm by yamamtx

» Steering rack clearance
Wed Oct 04, 2017 6:14 am by remaxagent33

» Does anyone have a QuickTime bellhousing for sale?
Tue Oct 03, 2017 11:54 pm by zeusrotty

October 2017
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Calendar Calendar

Log in

I forgot my password


HELP!!! Replaced hydroboost and master and now I have a soft pedal.

View previous topic View next topic Go down

HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  zeusrotty on Wed Oct 26, 2016 7:30 pm

I am trying to diagnose a brake problem and I need help. My car is running a Ford hydro-boost and after reinstalling it because of head work I cant get a hard pedal to save my life. I have bled the hydro-boost itself, and bled the brake master itself and then also bled all four corners. Both units are new. I cant figure out if I still have air in the hydro-boost or if I need to bleed the master or both... Also, I am running soft lines from the master so I am wondering if that effected everything... Even though they are high quality flex line...

Is my next step to plug each of the holes in the master to see if the issue is beyond that point? The shop I do my work out of is perplexed also because we have tried everything. We know the hydro-boost can notoriously be hard to bleed but we have done it over and over. I guess it could still have trapped air... But yeesh... We thought it was the master and the Ford hydro-boost but like I said I just replaced them after running into this issue.

Hydro-boost is from a 2000 Mustang Cobra, and the power steering is working.



I have a soft pedal when it is running... goes all the way to the floor. When it isn't running pedal gets hard but engagement is low.  should I rebleed master on each port with bleeder screws? Are the soft lines an issue? Should I block off ports to see if it is an issue in the master or past it?

Also is there supposed to be a input shaft on the 944 master and also the input shaft from the hydroboost? I put this damn thing together but I can't remember for the life of me.

zeusrotty

Posts : 432
Join date : 2010-07-30

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  Hotrodz of Dallas on Thu Oct 27, 2016 9:22 am

I have had the same problem, but only when using the ford master cylinder. With the 944 master, I have a pressure bleeder and it works every time. I have since ordered a pressure bleeder cap for the ford master. You can loosen the lines at the master cylinder one at a time and bleed there to insure no air in the master.
There is a rod between the 944 master and the hydroboost. Almost sounds like it may have been left out.
avatar
Hotrodz of Dallas

Posts : 151
Join date : 2015-10-31
Age : 59
Location : Dallas-Ft. Worth

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  zeusrotty on Thu Oct 27, 2016 10:18 am

Does anyone have the length of the second input rod for the 944 master? And to be clear there is a second input rod... the hydroboost rod is there, but no rod after that.

zeusrotty

Posts : 432
Join date : 2010-07-30

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  Hotrodz of Dallas on Thu Oct 27, 2016 10:20 am

zeusrotty wrote:Does anyone have the length of the second input rod for the 944 master?  And to be clear there is a second input rod... the hydroboost rod is there, but no rod after that.

I can call Kent at TPC and see if he knows the length. I don't have one atm.

You have the pushrod that attaches the HB to the brake pedal, and then you have the rod inside the HB where the master cylinder attaches.
avatar
Hotrodz of Dallas

Posts : 151
Join date : 2015-10-31
Age : 59
Location : Dallas-Ft. Worth

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  dsrracer on Thu Oct 27, 2016 10:52 am

I have the rod length at home (4.??") , I can post it in a couple or 3 hours. I'm having the opposite problem, with the pedal hard and the brakes locking and continuing to drag after you let off the pedal. What do you mean a second shaft? I only have one shaft between the hydro boost and the 951 MC.
avatar
dsrracer

Posts : 55
Join date : 2015-11-04
Location : Benton Ks

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  zeusrotty on Thu Oct 27, 2016 11:16 am

Okay then that isn't my issue, because I have both of those rods also... I guess I didn't consider the pedal clevis a rod... Or input shaft...

So my issue isn't that. Does anyone know if there is a machine that will bleed the hydraulic system (hydro-boost, and the power steering)?

zeusrotty

Posts : 432
Join date : 2010-07-30

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  dsrracer on Thu Oct 27, 2016 6:33 pm

My hydroboost input shat is 4.80 in long if that helps.
avatar
dsrracer

Posts : 55
Join date : 2015-11-04
Location : Benton Ks

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  2SD on Tue Nov 01, 2016 7:53 pm

I'm actually having a combination of the 2 problems listed here. I have a very long pedal before I get any brake pressure but they also drag pretty strongly. Anyone experienced this before?

I have adjusted the clevis as far out as I can but it didn't really help. Before I did that I actually had a very nice hard pedal. Then all of a sudden it's super long. I've considered shortening the rod between the master and booster but I don't think that will help with the long pedal issue. The next step may be shortening the clevis which will be a PITA.

Using Ford hydroboost and 951 master.

2SD

Posts : 2
Join date : 2015-10-22

Back to top Go down

Re: HELP!!! Replaced hydroboost and master and now I have a soft pedal.

Post  sharkey on Wed Nov 02, 2016 12:38 am

unbolt the master cylinder, do it evenly, and see if it looks like its being pushed off the booster. to me it sounds like the pushrod between the booster and master is too long and holding the master on. this would cause it to drag, and the long pedal could be because the passage from the resevior to the cylinder is blocked by the piston and not allowing fluid to enter it.

sharkey

Posts : 410
Join date : 2014-11-21
Age : 33
Location : Abbotsford BC

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum