HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» FiTech option
Thu Sep 20, 2018 2:06 pm by sharkey

» Hydroboost? 1/2" Spacers?
Thu Sep 20, 2018 9:16 am by remaxagent33

» Drag set up
Tue Sep 18, 2018 5:47 pm by Ij944

» FS ABS Powerbrake system pressure pumps
Tue Sep 18, 2018 1:09 pm by jpr

» A/C parts used for the swap !
Tue Sep 18, 2018 10:43 am by Rothaus

» LSA Supercharged 86 Porsche 944
Tue Sep 18, 2018 10:13 am by Ij944

» 82 924 with AUX Audi V8.
Tue Sep 18, 2018 3:17 am by Golten1986

» Clutch Issues - HELP!!!
Mon Sep 17, 2018 11:16 am by chrenan

» 1987 944 Turbo --> LS
Mon Sep 17, 2018 10:08 am by chrenan

» Brand new ls3 build
Sun Sep 16, 2018 7:46 pm by Plucky948

September 2018
MonTueWedThuFriSatSun
     12
3456789
10111213141516
17181920212223
24252627282930

Calendar Calendar

Log in

I forgot my password


Oil Cooler Adapter Not Working?

Go down

Oil Cooler Adapter Not Working?

Post  jpkinerk on Wed Oct 11, 2017 8:22 pm

I recently installed an oil cooler adapter from Improved Racing (LS low profile), got the oil up to temp and the actual cooler is still...cold. Temp sensor is showing 240 degrees and I still have good oil pressure, so I'm guessing the thermostat in the adapter is bad? I just can't believe I'd have bad enough luck to get a new part with a failed thermostat. I REALLY don't want to take that all apart again, very tight in there.

Anything I could be missing?
avatar
jpkinerk

Posts : 168
Join date : 2013-02-13

Back to top Go down

Re: Oil Cooler Adapter Not Working?

Post  sharkey on Wed Oct 11, 2017 9:32 pm

might be helpful to share more about your setup. what oil pan do you have? are you running a remote oil filter?

sharkey

Posts : 546
Join date : 2014-11-21
Age : 34
Location : Abbotsford BC

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum