HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» Dual MC Mounting Bracket
Today at 8:11 pm by 87944turbo

» What LS Exhaust Manifolds / Headers
Today at 7:50 pm by hp18racer

» Procharged LS1 Swapped 1988 944S
Today at 5:20 pm by dougr944

» Need help! Car won’t start
Today at 3:51 pm by jess2suityou

» 1997 C5 LS1 5.7 806 Valve Covers Driver side Needs mod
Today at 9:44 am by keetle

» Brand new ls3 build
Today at 9:32 am by Plucky948

» Lighten clutch pedal feel?
Today at 1:35 am by Porsche951toLS3

» 1987 944 Turbo --> LS
Yesterday at 9:54 am by docwyte

» Early BH from Renegade Hybrids?
Fri Jan 18, 2019 2:53 am by spence

» LSA Supercharged 86 Porsche 944
Thu Jan 17, 2019 8:49 pm by superman22x

January 2019
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   

Calendar Calendar

Log in

I forgot my password


MAF trouble shooting. help needed!

Go down

MAF trouble shooting. help needed!

Post  kelleysj on Sun Sep 22, 2013 7:18 am

I know with the MAF sensor the car should really come to life but mine seems to want to make the car stall at idle and kinda stutter and almost miss out or sound that way anyway. It runs pretty well with it unplugged but as soon as i plug it in its back to its usually antics. I have reset the computer to see if that would help but that was a no go. Any insight, has anyone dealt with this before? Thanks guys.
avatar
kelleysj

Posts : 186
Join date : 2010-03-16
Age : 36
Location : Logansport, IN

Back to top Go down

Re: MAF trouble shooting. help needed!

Post  spence on Sun Sep 22, 2013 7:49 am

Do you have any kind of logging software? eg. Datamaster?

Is your engine totally stock?
avatar
spence

Posts : 552
Join date : 2009-07-21
Age : 36
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: MAF trouble shooting. help needed!

Post  Homeboy981 on Sun Sep 22, 2013 9:45 am

What has worked for me with my MAF was disconnecting the battery. Pulling the MAF and cleaning it CAREFULLY with carburetor cleaner and a lint free cloth. While you are there you can tidy up the intake tubing and it should help. Make sure to clean the connectors too.

If that fails you will want to get a reading as @Spence suggested. Autozone will do it for free - they have a scanner.
avatar
Homeboy981

Posts : 18
Join date : 2013-09-04
Location : Sherman, TX

Back to top Go down

Re: MAF trouble shooting. help needed!

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum