HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» Unfinished 1987 turbo ls2 conversion
Yesterday at 4:01 pm by Murrdog9000

» Team Moroney's LS1 944 Swap, In memory of Kyle Moroney.
Yesterday at 6:16 am by bikerdude

» 87 944 Turbo LS conversion decision
Yesterday at 2:33 am by Flashy2003

» ecotec swap
Yesterday at 12:13 am by sharkey

» The famous Hydroboost issues....
Wed Apr 18, 2018 11:30 pm by C4924S

» Tachometer Issues
Wed Apr 18, 2018 10:22 pm by 948

» 83' Porsche 944 LM7 Build
Wed Apr 18, 2018 7:12 am by Jchard944

» Corvette C6 Z06 Brake Caliper Adapters
Tue Apr 17, 2018 5:44 pm by superman22x

» Hydroboost problems
Tue Apr 17, 2018 1:35 pm by Hotrodz of Dallas

» WTB: 944 Turbo Roller
Mon Apr 16, 2018 12:29 pm by knight76

April 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
30      

Calendar Calendar

Log in

I forgot my password


MAF trouble shooting. help needed!

Go down

MAF trouble shooting. help needed!

Post  kelleysj on Sun Sep 22, 2013 7:18 am

I know with the MAF sensor the car should really come to life but mine seems to want to make the car stall at idle and kinda stutter and almost miss out or sound that way anyway. It runs pretty well with it unplugged but as soon as i plug it in its back to its usually antics. I have reset the computer to see if that would help but that was a no go. Any insight, has anyone dealt with this before? Thanks guys.
avatar
kelleysj

Posts : 186
Join date : 2010-03-16
Age : 35
Location : Logansport, IN

Back to top Go down

Re: MAF trouble shooting. help needed!

Post  spence on Sun Sep 22, 2013 7:49 am

Do you have any kind of logging software? eg. Datamaster?

Is your engine totally stock?
avatar
spence

Posts : 536
Join date : 2009-07-21
Age : 35
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: MAF trouble shooting. help needed!

Post  Homeboy981 on Sun Sep 22, 2013 9:45 am

What has worked for me with my MAF was disconnecting the battery. Pulling the MAF and cleaning it CAREFULLY with carburetor cleaner and a lint free cloth. While you are there you can tidy up the intake tubing and it should help. Make sure to clean the connectors too.

If that fails you will want to get a reading as @Spence suggested. Autozone will do it for free - they have a scanner.
avatar
Homeboy981

Posts : 18
Join date : 2013-09-04
Location : Sherman, TX

Back to top Go down

Re: MAF trouble shooting. help needed!

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum