944Hybrids: 924/944/968 and 928 V8 Conversions
Would you like to react to this message? Create an account in a few clicks or log in to continue.
HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» 1987 944 Turbo --> LS
It Runs! EmptyToday at 8:36 pm by Reason

» backwards LS6 intake
It Runs! EmptyToday at 6:24 pm by murrayg

» WTB C5 2 piece bell housing
It Runs! EmptyToday at 10:39 am by murrayg

» Testing the waters. I have a working '83 944 with a '94 LT1 that I want to let go.
It Runs! EmptyYesterday at 7:44 am by Bmillar

» FS: 1987 951 LS
It Runs! EmptyYesterday at 6:30 am by carr911

» Totalled 1985.5 Porsche 944
It Runs! EmptyFri Sep 18, 2020 3:53 pm by Bmillar

» Clutch wont disengage!
It Runs! EmptySun Sep 13, 2020 10:51 pm by RobotMachines

» tachometer
It Runs! EmptyFri Sep 11, 2020 10:21 am by smkn951

» 86 Porsche 944T LS1 swap begins
It Runs! EmptyThu Sep 10, 2020 9:31 pm by smkn951

» stalls when braking
It Runs! EmptyThu Sep 10, 2020 10:55 am by spence

September 2020
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
282930    

Calendar Calendar

Log in

I forgot my password

It Runs!

Go down

It Runs! Empty Exhaust: Track Car Build Update

Post  968gene on Sun Apr 25, 2010 8:58 pm

Thought I would share a few pics of the exhaust. one flex joint, one 4' stick of 3" tubing, two 45* bends, one muffler, one turn down, and modified stock hangers.

[You must be registered and logged in to see this image.]
[You must be registered and logged in to see this image.]
[You must be registered and logged in to see this image.]
[You must be registered and logged in to see this image.]
968gene
968gene

Posts : 256
Join date : 2009-07-02

Back to top Go down

It Runs! Empty Re: It Runs!

Post  Luke714 on Mon Apr 26, 2010 3:04 pm

what muffler is that?
Luke714
Luke714

Posts : 441
Join date : 2009-12-30
Age : 30
Location : Maine

Back to top Go down

It Runs! Empty muffler

Post  968gene on Mon Apr 26, 2010 3:57 pm

It's a Dynatech...not a street muffler. Basically straight thru.
968gene
968gene

Posts : 256
Join date : 2009-07-02

Back to top Go down

It Runs! Empty Re: It Runs!

Post  Luke714 on Mon Apr 26, 2010 4:07 pm

ah, ok. I was looking at those. I want to run a 3.5" single, but I can't find much in that diameter. Is this what you've got, more or less? [You must be registered and logged in to see this link.]

How loud is it? Much too loud for the street I'm assuming? Could you recommend anything in 3.5"?
Luke714
Luke714

Posts : 441
Join date : 2009-12-30
Age : 30
Location : Maine

Back to top Go down

It Runs! Empty muffler

Post  968gene on Mon Apr 26, 2010 4:17 pm

I did get it from Summit. Haven't started the car yet, but it will be too loud for the street. 3.5" might be overkill, depending on the size of your engine and the mods.
968gene
968gene

Posts : 256
Join date : 2009-07-02

Back to top Go down

It Runs! Empty Re: It Runs!

Post  Luke714 on Mon Apr 26, 2010 4:25 pm

it might be, but I don't think it'll hurt the torque if I put it on just so that I have room to grow. A couple of guys here are running even more pipe and claim to have no torque loss on the dyno.

This might be more reasonable, but still pretty aggressive: [You must be registered and logged in to see this link.]
Luke714
Luke714

Posts : 441
Join date : 2009-12-30
Age : 30
Location : Maine

Back to top Go down

It Runs! Empty It Runs!

Post  968gene on Sun Jun 27, 2010 6:29 am

[You must be registered and logged in to see this link.]
968gene
968gene

Posts : 256
Join date : 2009-07-02

Back to top Go down

It Runs! Empty Re: It Runs!

Post  modenas on Sun Jun 27, 2010 7:11 am

congratulation, so what next?
modenas
modenas

Posts : 285
Join date : 2009-06-08
Age : 31
Location : lubbock tx

Back to top Go down

It Runs! Empty Re: It Runs!

Post  Arthropraxis on Sun Jun 27, 2010 8:57 am

Thats great! So when is the first drive?
Arthropraxis
Arthropraxis

Posts : 1103
Join date : 2009-09-02

Back to top Go down

It Runs! Empty Update

Post  968gene on Sun Jun 27, 2010 4:23 pm

What's next? Brakes, alignment, safety equipment...the list is getting shorter!
968gene
968gene

Posts : 256
Join date : 2009-07-02

Back to top Go down

It Runs! Empty Re: It Runs!

Post  stuart f. wright on Sun Jun 27, 2010 7:04 pm

awesome sounds and looks good
stuart f. wright
stuart f. wright

Posts : 297
Join date : 2009-07-19
Age : 58
Location : effingham illinois

Back to top Go down

It Runs! Empty Re: It Runs!

Post  a951 on Mon Jun 28, 2010 3:40 am

love it!

a951

Posts : 121
Join date : 2010-05-17

Back to top Go down

It Runs! Empty Re: It Runs!

Post  Luke714 on Mon Jun 28, 2010 5:57 am

beautiful looking engine bay, congratulations on the run!!
Luke714
Luke714

Posts : 441
Join date : 2009-12-30
Age : 30
Location : Maine

Back to top Go down

It Runs! Empty Re: It Runs!

Post  948 on Mon Jun 28, 2010 6:47 am

Congrats.....
948
948
Moderator
Moderator

Posts : 544
Join date : 2009-06-09
Age : 105
Location : East PA

Back to top Go down

It Runs! Empty Re: It Runs!

Post  xschop on Mon Jun 28, 2010 9:24 am

Congrats Gene. I admire your work. Can't wait to see the track video and the P-car pukes' expressions as you pass.... Embarassed
xschop
xschop

Posts : 2710
Join date : 2009-06-09
Location : OKC

Back to top Go down

It Runs! Empty It runs

Post  968gene on Mon Jun 28, 2010 9:31 pm

Thanks for the comments. I will post more pics when it track worthy. BTW, I made my own harness by robbing a Tahoe and an F body harness. Had a hiccup because I missed a few PCM ground wires. Once that was wrapped up, the car started immediately. To recap, I'm using an L33 with a Comp Cam, an LS6 intake, and GTO PCM. I'll also post sheets from a dyno tune in time.
968gene
968gene

Posts : 256
Join date : 2009-07-02

Back to top Go down

It Runs! Empty Re: It Runs!

Post  944-LT1 on Mon Jul 05, 2010 12:21 pm

Hey! Nicely done! Very Happy

_________________
[You must be registered and logged in to see this image.]

[You must be registered and logged in to see this link.]
944-LT1
944-LT1
Moderator
Moderator

Posts : 1263
Join date : 2009-06-09
Age : 98
Location : NOTRE DAME

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum