944Hybrids: 924/944/968 and 928 V8 Conversions
Would you like to react to this message? Create an account in a few clicks or log in to continue.
HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» Honda k24 swap
motor mount fail EmptySat Oct 24, 2020 9:42 pm by jso944

» low cost and available bellhousing...maybe
motor mount fail EmptySat Oct 24, 2020 3:34 pm by Hotrodz of Dallas

» 85 5.3 swap
motor mount fail EmptyFri Oct 23, 2020 7:46 pm by tonyorlo

» Kooks headers on eBay
motor mount fail EmptyThu Oct 22, 2020 8:54 pm by Admin

» Starter issues
motor mount fail EmptySun Oct 18, 2020 12:48 pm by zeusrotty

» Sharkey's 944 corvette t56 swap thread
motor mount fail EmptyTue Oct 13, 2020 10:01 am by Myporschels

» FS: 1987 951 LS
motor mount fail EmptyTue Oct 13, 2020 5:41 am by carr911

» 5th gear options, Audi?
motor mount fail EmptyMon Oct 12, 2020 1:18 pm by acorad

» Garage queens
motor mount fail EmptyMon Oct 12, 2020 11:57 am by gdopnt

» Where did you find your LS1? I need one :)
motor mount fail EmptySun Oct 11, 2020 10:33 pm by smkn951

October 2020
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
262728293031 

Calendar Calendar

Log in

I forgot my password

motor mount fail

Go down

motor mount fail Empty motor mount fail

Post  murrayg on Tue Jul 02, 2019 9:31 am

Hi all,

The car just dropped the fastener for the left motor mount.  It's the mount to cross member end.  Before I jack the thing up at lunch (at work), any idea what I need?  I think it's a stud, so I need the nut and washer......assuming the stud didn't break.  Thread and size, anyone??

Thanks,
Gord.

##- EDIT Just under the car....the stud is broken off flush with the bottom of the motor mount.  Any suggestions??  Is this common??

Thanks again,
Gord.

murrayg

Posts : 93
Join date : 2012-12-15

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  acorad on Tue Jul 02, 2019 1:50 pm

Several different motor mounts on the market, who produced yours?

acorad
acorad

Posts : 679
Join date : 2010-12-21
Location : Agoura Hills, CA

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  murrayg on Tue Jul 02, 2019 2:58 pm

who produced yours?

TPC.

I'll post a picture shortly.....

murrayg

Posts : 93
Join date : 2012-12-15

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  acorad on Tue Jul 02, 2019 3:09 pm

Does it look like this with the stud in the bottom sheared completely off?

[You must be registered and logged in to see this link.]
acorad
acorad

Posts : 679
Join date : 2010-12-21
Location : Agoura Hills, CA

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  murrayg on Tue Jul 02, 2019 3:28 pm

Does it look like this

yes.  I don't have it off yet, but it is like your photo.

It's off now. Exactly like yours.  Is there an issue here??  Whats the way forward?

Gord.
[You must be registered and logged in to see this link.]


Last edited by murrayg on Tue Jul 02, 2019 3:55 pm; edited 1 time in total

murrayg

Posts : 93
Join date : 2012-12-15

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  acorad on Tue Jul 02, 2019 3:39 pm

Both of my mounts failed, I think they were originally from Renegade in Vegas, although I don't know for sure. In addition to the sheared off stud, the rubber delaminated from the metal on both mounts. Probably from the unexpected forces on them due to the stud shearing off.

Anyway, I replaced them with TPC's new mounts.

You can read about it here: [You must be registered and logged in to see this link.]

Andy


Last edited by acorad on Tue Jul 02, 2019 4:52 pm; edited 1 time in total
acorad
acorad

Posts : 679
Join date : 2010-12-21
Location : Agoura Hills, CA

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  murrayg on Tue Jul 02, 2019 4:04 pm

another shot.  These aren't Renegade.
[You must be registered and logged in to see this link.]

murrayg

Posts : 93
Join date : 2012-12-15

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  acorad on Tue Jul 02, 2019 4:53 pm

Ya, those are the same ones I had that failed. Maybe some previous version from TPC?

Andy


Last edited by acorad on Mon Jul 08, 2019 10:20 am; edited 1 time in total
acorad
acorad

Posts : 679
Join date : 2010-12-21
Location : Agoura Hills, CA

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  Rich L. on Thu Jul 04, 2019 10:17 pm

Yes! I had that same failure on one side back in 2014. Eric (he was still running TPC) made me a set of mounts with hardened bolts. But those had the plastic bushings disintegrate. But I mixed and matched, new mounts with old bushings and they're still going strong today.
Rich L.
Rich L.

Posts : 892
Join date : 2011-05-30
Location : Seattle

Back to top Go down

motor mount fail Empty Re: motor mount fail

Post  docwyte on Tue Jul 09, 2019 7:56 am

I had three sets of TPC mounts fail. Broke each revision of them.

docwyte

Posts : 1390
Join date : 2010-07-18

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum