944Hybrids: 924/944/968 and 928 V8 Conversions
Would you like to react to this message? Create an account in a few clicks or log in to continue.
HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» 1987 944 Turbo --> LS
Belt squeal after hydroboost? EmptyToday at 8:36 pm by Reason

» backwards LS6 intake
Belt squeal after hydroboost? EmptyToday at 6:24 pm by murrayg

» WTB C5 2 piece bell housing
Belt squeal after hydroboost? EmptyToday at 10:39 am by murrayg

» Testing the waters. I have a working '83 944 with a '94 LT1 that I want to let go.
Belt squeal after hydroboost? EmptyYesterday at 7:44 am by Bmillar

» FS: 1987 951 LS
Belt squeal after hydroboost? EmptyYesterday at 6:30 am by carr911

» Totalled 1985.5 Porsche 944
Belt squeal after hydroboost? EmptyFri Sep 18, 2020 3:53 pm by Bmillar

» Clutch wont disengage!
Belt squeal after hydroboost? EmptySun Sep 13, 2020 10:51 pm by RobotMachines

» tachometer
Belt squeal after hydroboost? EmptyFri Sep 11, 2020 10:21 am by smkn951

» 86 Porsche 944T LS1 swap begins
Belt squeal after hydroboost? EmptyThu Sep 10, 2020 9:31 pm by smkn951

» stalls when braking
Belt squeal after hydroboost? EmptyThu Sep 10, 2020 10:55 am by spence

September 2020
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
282930    

Calendar Calendar

Log in

I forgot my password

Belt squeal after hydroboost?

Go down

Belt squeal after hydroboost? Empty Belt squeal after hydroboost?

Post  Porch on Fri Jan 25, 2013 2:57 pm

I added hydroboost to my system a few months ago and have been battling some belt squeal since then.

The squeal occurs only after the engine has gotten nice and warm (after a longer drive), and only on deceleration.

I believe the squeal is coming from the power steering pump. I have already replaced one suspect idler pulley and put in a new alternator (the old one had a squeaky bearing). Everything else is in great shape! I have not replaced my belt, but i have a spare standing by. The current belt is a nice gatorback which has ~40k on it, but no cracks or weird wear. I just don't think it's the problem!

I wondered if maybe my powersteering fluid is getting too hot. I have a small cooler up front but could definitely afford to go larger.

I also wondered how people plumbed their return lines. My two return lines (one from the rack, one from the hydroboost) are tee'd together with a brass tee about one inch below the reservoir.

Steering and brakes are both working great. Any ideas?
Porch
Porch

Posts : 851
Join date : 2009-09-02
Age : 39

Back to top Go down

Belt squeal after hydroboost? Empty Re: Belt squeal after hydroboost?

Post  948inVA on Sat Jan 26, 2013 4:39 pm

The only time I've experienced belt squeal was when I had a minor cooling hose leak, and it was leaking coolant onto the belt. It would make the belt squeal for a few seconds on startup.
948inVA
948inVA

Posts : 222
Join date : 2012-01-01
Location : n. virginia

Back to top Go down

Belt squeal after hydroboost? Empty Re: Belt squeal after hydroboost?

Post  Admin on Sat Jan 26, 2013 4:59 pm

Double and triple check your belt alignment. That is the only belt problem we have had. Also make sure the belt is the right length. Just a 1/4" makes a difference. I have run the hydro boost setups without a cooler with no heating problems.

Admin
Admin
Admin

Posts : 1438
Join date : 2009-06-08
Age : 62
Location : Arlington,Texas

http://www.TexasPerformanceConcepts.com

Back to top Go down

Belt squeal after hydroboost? Empty Re: Belt squeal after hydroboost?

Post  Porch on Sun Jan 27, 2013 10:37 am

Okay, good to know! I just wanted to make sure i didn't need a cooler and my "T" connection was okay.

I'm certain the belt is the right length. I have started to wonder if i spilled something on the belt while i was doing the swap. I'll just swap it out and go from there.
Porch
Porch

Posts : 851
Join date : 2009-09-02
Age : 39

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum