HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» ecotec swap
Today at 12:29 pm by sharkey

» What is VSS?
Yesterday at 10:53 am by C4924S

» The famous Hydroboost issues....
Yesterday at 10:43 am by Hotrodz of Dallas

» RHD Conversion Issues...
Sun Apr 22, 2018 4:24 pm by UK952

» Considering doing LS1 Swap
Sat Apr 21, 2018 10:29 pm by hooplajr5

» WTB: 944 Turbo Roller
Sat Apr 21, 2018 8:31 am by Maxx

» Blue Alternator Wire
Fri Apr 20, 2018 11:22 pm by Porsche951toLS3

» Unfinished 1987 turbo ls2 conversion
Thu Apr 19, 2018 4:01 pm by Murrdog9000

» Team Moroney's LS1 944 Swap, In memory of Kyle Moroney.
Thu Apr 19, 2018 6:16 am by bikerdude

» 87 944 Turbo LS conversion decision
Thu Apr 19, 2018 2:33 am by Flashy2003

April 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
30      

Calendar Calendar

Log in

I forgot my password


This Hydroboost system is going to drive me nuts

Go down

This Hydroboost system is going to drive me nuts

Post  Red944ls1 on Mon Mar 12, 2018 7:54 pm

I figured I'd take the car out this weekend cuz I was back in town.  My power steering system is driving me crazy.  Initially I thought it was the GM pump that was causing the issue.  I changed out for a Cadillac CTS-V pump as it gave more pressure then the GM pump.  It worked fine for probably about 5 minutes. I'm assuming as the fluid heated up it stopped working.  I have no idea what the problem is I'm thinking the air is getting into the system and therefore causing it no longer to work when I let the car sit overnight and start it after it has been sitting it works fine for the first 5 minutes or so.

Any thoughts?


[You must be registered and logged in to see this link.]

Red944ls1

Posts : 71
Join date : 2012-08-02

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  sharkey on Mon Mar 12, 2018 9:04 pm

the power steering reservoir where it is, and the long hose is going to cause you a ton of issues. power steering pumps dont like to suck fluid, they need to be gravity fed. the long hose with multiple bends is likely not keeping the pump fed, and as soon as that happens the pump cavitates and starts making noise.

the first thing id do is figure out a fluid reservoir as close to the pump as possible. im thinking something like a gto reservoir. you will have to add the extra return fitting for the hydroboost to that one, could use a self sealing bulkhead fitting, or get an aluminum version and have an extra nipple welded on.

sharkey

Posts : 505
Join date : 2014-11-21
Age : 33
Location : Abbotsford BC

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  P911P951 on Tue Mar 13, 2018 6:57 am

Using ATF right?

Jack

P911P951

Posts : 48
Join date : 2013-06-29

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  Red944ls1 on Tue Mar 13, 2018 10:46 pm

Yes..atf...before I switched to the CTS-V pump I was using CHF.

I still don't get why it works perfectly fine until the car has been running for about 5 minutes.

Red944ls1

Posts : 71
Join date : 2012-08-02

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum