HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» HOW TO DO AN ADVANCED SEARCH.
Yesterday at 10:26 pm by Guitmn

» light delete badge panel.
Yesterday at 8:58 pm by x.l.r.8

» Early / late suspension
Sat Oct 13, 2018 5:52 am by Guitmn

» 944 LSD turbo/NA transaxle
Sat Oct 13, 2018 5:01 am by murrayg

» Used Throw Out bearing
Fri Oct 12, 2018 9:18 pm by Admin

» Used C5 Adapter Plate for 2 piece bellhousing
Fri Oct 12, 2018 9:08 pm by Admin

» axles and cv joints
Fri Oct 12, 2018 12:03 pm by kevin924kevin

» Holley Pro Street Annihilator Ignition system
Thu Oct 11, 2018 7:39 pm by x.l.r.8

» Fuel pump for carb.
Thu Oct 11, 2018 6:29 pm by x.l.r.8

» radiator and fan
Thu Oct 11, 2018 4:44 pm by matt889

October 2018
MonTueWedThuFriSatSun
1234567
891011121314
15161718192021
22232425262728
293031    

Calendar Calendar

Log in

I forgot my password


This Hydroboost system is going to drive me nuts

Go down

This Hydroboost system is going to drive me nuts

Post  Red944ls1 on Mon Mar 12, 2018 7:54 pm

I figured I'd take the car out this weekend cuz I was back in town.  My power steering system is driving me crazy.  Initially I thought it was the GM pump that was causing the issue.  I changed out for a Cadillac CTS-V pump as it gave more pressure then the GM pump.  It worked fine for probably about 5 minutes. I'm assuming as the fluid heated up it stopped working.  I have no idea what the problem is I'm thinking the air is getting into the system and therefore causing it no longer to work when I let the car sit overnight and start it after it has been sitting it works fine for the first 5 minutes or so.

Any thoughts?


[You must be registered and logged in to see this link.]

Red944ls1

Posts : 73
Join date : 2012-08-02

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  sharkey on Mon Mar 12, 2018 9:04 pm

the power steering reservoir where it is, and the long hose is going to cause you a ton of issues. power steering pumps dont like to suck fluid, they need to be gravity fed. the long hose with multiple bends is likely not keeping the pump fed, and as soon as that happens the pump cavitates and starts making noise.

the first thing id do is figure out a fluid reservoir as close to the pump as possible. im thinking something like a gto reservoir. you will have to add the extra return fitting for the hydroboost to that one, could use a self sealing bulkhead fitting, or get an aluminum version and have an extra nipple welded on.

sharkey

Posts : 554
Join date : 2014-11-21
Age : 34
Location : Abbotsford BC

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  P911P951 on Tue Mar 13, 2018 6:57 am

Using ATF right?

Jack

P911P951

Posts : 48
Join date : 2013-06-29

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  Red944ls1 on Tue Mar 13, 2018 10:46 pm

Yes..atf...before I switched to the CTS-V pump I was using CHF.

I still don't get why it works perfectly fine until the car has been running for about 5 minutes.

Red944ls1

Posts : 73
Join date : 2012-08-02

Back to top Go down

Re: This Hydroboost system is going to drive me nuts

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum