HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» LS3 conversion
Today at 12:30 pm by sharkey

» 944 with LS3 Brake Fluid Fire Mistake
Today at 8:54 am by Rich L.

» Boxster Rear Calipers
Yesterday at 5:04 pm by AMFCSL

» Transaxle rebuild
Fri Jul 20, 2018 9:24 pm by sharkey

» Noisy VSS and stalling???
Fri Jul 20, 2018 8:27 pm by matt889

» Hello, Gentlemen.
Fri Jul 20, 2018 7:43 pm by rawr

» alignment specs
Fri Jul 20, 2018 12:53 am by sharkey

» A/C parts used for the swap !
Thu Jul 19, 2018 8:04 pm by Rothaus

» Drive shaft too short to reach pilot bearning
Wed Jul 18, 2018 10:28 pm by spence

» 944 with LS3 bucking or jerking while cruising or low speed problem
Tue Jul 17, 2018 12:44 am by Porsche951toLS3

July 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Calendar Calendar

Log in

I forgot my password


Engine fails when getting warm under load or idling

Go down

Engine fails when getting warm under load or idling

Post  quarterflash on Mon Nov 23, 2015 3:59 am

Hi everyone
We had our first frost of the year here in the UK last night. Brrr.

Maybe you can suggest a solution to our problem.
Engine: 95 Corvette LT1 350.
Car: 89 944 Turbo, well it was.
Problem: engines takes a while to start but then fires up and runs fine. However after driving for a short while or even idling it splutters to a halt. Leaving it to cool down allows us to start it again no problem.
I don't want to put ideas in your head but does that sound like a coil issue?
All cylinder compressions are good (175 - 200) and it is not restricted to a cylinder or even a bank of 4. The whole engine is affected so it has to be coil, distributor or fuel?

All ideas welcome.
Thanks
Q

quarterflash

Posts : 70
Join date : 2010-08-04
Location : Stratford-Upon-Avon, UK

http://porschevy.co.uk/

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  spence on Mon Nov 23, 2015 5:07 am

Sounds like an optispark or ICM issue.... Read this

[You must be registered and logged in to see this link.]

avatar
spence

Posts : 539
Join date : 2009-07-21
Age : 36
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  kelleysj on Thu Dec 10, 2015 8:37 am

I had this issue with my ICM. I spaced the heatsink with washers since I believed it was overheating due to being mounted to the driver side head. I also removed the ICM from the heat sink cleaned all the old paste off and added Artic silver5 heat sink paste to the sink and ICM remounted it. Since I have done this I have not had one problem with the car dying. This is a cheaper fix to try first before messing with the opti.
avatar
kelleysj

Posts : 186
Join date : 2010-03-16
Age : 36
Location : Logansport, IN

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  quarterflash on Thu Dec 10, 2015 8:51 am

Thanks for your help kelleysj. However the diagnostic that has been run since posting this problem indicates an Optispark issue. So a shiny new unit is on its way. I will post the answer when we get it sorted.
Incidentally where have you mounted the ICM. Looks like mine will be under the dashboard with the two brake servos.
Regards
Q

quarterflash

Posts : 70
Join date : 2010-08-04
Location : Stratford-Upon-Avon, UK

http://porschevy.co.uk/

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  spence on Thu Dec 10, 2015 10:54 am

What kind of optispark did you buy? I hope you got an MSD or AC delco OEM replacement.... Anything else is crap and wont last.
avatar
spence

Posts : 539
Join date : 2009-07-21
Age : 36
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  quarterflash on Thu Dec 10, 2015 11:10 am

It was a difficult decision - do I spend £380 or £180? Especially as I suspect MSD and Ac Delco is made in china these days.
Regards
Q

quarterflash

Posts : 70
Join date : 2010-08-04
Location : Stratford-Upon-Avon, UK

http://porschevy.co.uk/

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  spence on Thu Dec 10, 2015 11:18 am

Yes, the MSD and AC delco cost is more; but I'd still go with those. It's not worth having to pull everything off the front of the engine to do it again... The cheap ones are known for having issues right out of the box.
avatar
spence

Posts : 539
Join date : 2009-07-21
Age : 36
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum