HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» Changing Position of Air Filter Intake
Today at 12:03 pm by superman22x

» ecotec swap
Yesterday at 8:41 pm by sharkey

» 86` 944 turbo project
Yesterday at 6:33 pm by 948

» Total number of LS conversions?
Yesterday at 6:27 pm by 948

» LS3 Exhaust
Yesterday at 4:29 pm by Hotrodz of Dallas

» alignment specs
Yesterday at 4:22 pm by Hotrodz of Dallas

» 1984 Gen IV 5.3 Swap
Yesterday at 2:03 pm by superman22x

» Question about 964 transmission into 924s/944
Thu Jan 18, 2018 1:52 pm by Hamr20

» New convert under way
Thu Jan 18, 2018 12:36 pm by sharkey

» For sale $150 Griffin for LS1 LS Radiator swap
Thu Jan 18, 2018 12:33 am by jshprd

January 2018
MonTueWedThuFriSatSun
1234567
891011121314
15161718192021
22232425262728
293031    

Calendar Calendar

Log in

I forgot my password


Engine fails when getting warm under load or idling

View previous topic View next topic Go down

Engine fails when getting warm under load or idling

Post  quarterflash on Mon Nov 23, 2015 3:59 am

Hi everyone
We had our first frost of the year here in the UK last night. Brrr.

Maybe you can suggest a solution to our problem.
Engine: 95 Corvette LT1 350.
Car: 89 944 Turbo, well it was.
Problem: engines takes a while to start but then fires up and runs fine. However after driving for a short while or even idling it splutters to a halt. Leaving it to cool down allows us to start it again no problem.
I don't want to put ideas in your head but does that sound like a coil issue?
All cylinder compressions are good (175 - 200) and it is not restricted to a cylinder or even a bank of 4. The whole engine is affected so it has to be coil, distributor or fuel?

All ideas welcome.
Thanks
Q

quarterflash

Posts : 68
Join date : 2010-08-04
Location : Stratford-Upon-Avon, UK

http://porschevy.co.uk/

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  spence on Mon Nov 23, 2015 5:07 am

Sounds like an optispark or ICM issue.... Read this

[You must be registered and logged in to see this link.]

avatar
spence

Posts : 536
Join date : 2009-07-21
Age : 35
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  kelleysj on Thu Dec 10, 2015 8:37 am

I had this issue with my ICM. I spaced the heatsink with washers since I believed it was overheating due to being mounted to the driver side head. I also removed the ICM from the heat sink cleaned all the old paste off and added Artic silver5 heat sink paste to the sink and ICM remounted it. Since I have done this I have not had one problem with the car dying. This is a cheaper fix to try first before messing with the opti.
avatar
kelleysj

Posts : 186
Join date : 2010-03-16
Age : 35
Location : Logansport, IN

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  quarterflash on Thu Dec 10, 2015 8:51 am

Thanks for your help kelleysj. However the diagnostic that has been run since posting this problem indicates an Optispark issue. So a shiny new unit is on its way. I will post the answer when we get it sorted.
Incidentally where have you mounted the ICM. Looks like mine will be under the dashboard with the two brake servos.
Regards
Q

quarterflash

Posts : 68
Join date : 2010-08-04
Location : Stratford-Upon-Avon, UK

http://porschevy.co.uk/

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  spence on Thu Dec 10, 2015 10:54 am

What kind of optispark did you buy? I hope you got an MSD or AC delco OEM replacement.... Anything else is crap and wont last.
avatar
spence

Posts : 536
Join date : 2009-07-21
Age : 35
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  quarterflash on Thu Dec 10, 2015 11:10 am

It was a difficult decision - do I spend £380 or £180? Especially as I suspect MSD and Ac Delco is made in china these days.
Regards
Q

quarterflash

Posts : 68
Join date : 2010-08-04
Location : Stratford-Upon-Avon, UK

http://porschevy.co.uk/

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  spence on Thu Dec 10, 2015 11:18 am

Yes, the MSD and AC delco cost is more; but I'd still go with those. It's not worth having to pull everything off the front of the engine to do it again... The cheap ones are known for having issues right out of the box.
avatar
spence

Posts : 536
Join date : 2009-07-21
Age : 35
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine fails when getting warm under load or idling

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum