HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» LS3 conversion
Today at 12:30 pm by sharkey

» 944 with LS3 Brake Fluid Fire Mistake
Today at 8:54 am by Rich L.

» Boxster Rear Calipers
Yesterday at 5:04 pm by AMFCSL

» Transaxle rebuild
Fri Jul 20, 2018 9:24 pm by sharkey

» Noisy VSS and stalling???
Fri Jul 20, 2018 8:27 pm by matt889

» Hello, Gentlemen.
Fri Jul 20, 2018 7:43 pm by rawr

» alignment specs
Fri Jul 20, 2018 12:53 am by sharkey

» A/C parts used for the swap !
Thu Jul 19, 2018 8:04 pm by Rothaus

» Drive shaft too short to reach pilot bearning
Wed Jul 18, 2018 10:28 pm by spence

» 944 with LS3 bucking or jerking while cruising or low speed problem
Tue Jul 17, 2018 12:44 am by Porsche951toLS3

July 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Calendar Calendar

Log in

I forgot my password


Engine stall under load

Go down

Engine stall under load

Post  Torc_TX on Wed Oct 22, 2014 8:47 am

Just finishing up a swap with a 5.3 using the Ford Mustang hydro boost and I'm having a problem. When I press the brake or turn the steering wheel with it idling it immediately kill the engine. I’ve been searching forums and wracking my brain over this, has anyone experienced anything similar? I'm probably overlooking something and I'm sure it's somthing simple but for the life of me I haven't been able to figure it out.

Torc_TX

Posts : 3
Join date : 2013-11-04
Location : Fort Worth, TX

Back to top Go down

Re: Engine stall under load

Post  spence on Wed Oct 22, 2014 9:22 am

Is the idle control valve working properly? Do you have a scanner to check for codes / read iac count?
avatar
spence

Posts : 539
Join date : 2009-07-21
Age : 36
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine stall under load

Post  zeusrotty on Wed Oct 22, 2014 3:30 pm

What throttle body do you have?

zeusrotty

Posts : 434
Join date : 2010-07-30

Back to top Go down

Re: Engine stall under load

Post  Torc_TX on Wed Oct 22, 2014 5:51 pm

Scanner doesn't read any codes.  I'm not sure about IAC count.  It's also bogging down on WOT.

Torc_TX

Posts : 3
Join date : 2013-11-04
Location : Fort Worth, TX

Back to top Go down

Re: Engine stall under load

Post  racertomtom on Wed Oct 22, 2014 6:46 pm

Hydraulic line crossed?

racertomtom

Posts : 143
Join date : 2014-07-04
Age : 58
Location : Southern Illinois

Back to top Go down

Re: Engine stall under load

Post  Lemming on Thu Oct 23, 2014 7:44 am

racertomtom wrote:Hydraulic line crossed?

Yes, it sounds like there's too much back pressure on the PS pump, which is causing the stall.
avatar
Lemming

Posts : 855
Join date : 2011-05-30
Location : B'ham

Back to top Go down

Re: Engine stall under load

Post  Torc_TX on Thu Oct 23, 2014 8:07 am

Thanks, let me try that this afternoon when I get off.

Torc_TX

Posts : 3
Join date : 2013-11-04
Location : Fort Worth, TX

Back to top Go down

Re: Engine stall under load

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum