HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» RX7 Caliper Swap
Yesterday at 12:19 pm by osx86ftw

» 1987 944 Turbo --> LS
Tue Aug 22, 2017 11:52 pm by chrenan

» Which turbo trans for my swap application?
Mon Aug 21, 2017 8:10 pm by racertomtom

» Poly based strut mounts on exchange
Fri Aug 18, 2017 10:16 pm by xschop

» 18x10" Enkei wheels
Wed Aug 16, 2017 9:59 pm by Sterling Doc

» Around the block
Tue Aug 15, 2017 11:46 am by Red944ls1

» Cooling solutions please!
Sun Aug 13, 2017 3:15 pm by yamamtx

» Holley intake, vacuum pump and cross member spacer
Sun Aug 13, 2017 12:33 am by zeusrotty

» Sparkydog's Abnormal Build - 944 With L67 + Ford Stuff & CARB Legal
Sat Aug 12, 2017 3:42 pm by sparkydog

» LSA Supercharged 86 Porsche 944
Sat Aug 12, 2017 7:41 am by haroldk

August 2017
MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   

Calendar Calendar

Log in

I forgot my password


Engine stall under load

View previous topic View next topic Go down

Engine stall under load

Post  Torc_TX on Wed Oct 22, 2014 8:47 am

Just finishing up a swap with a 5.3 using the Ford Mustang hydro boost and I'm having a problem. When I press the brake or turn the steering wheel with it idling it immediately kill the engine. I’ve been searching forums and wracking my brain over this, has anyone experienced anything similar? I'm probably overlooking something and I'm sure it's somthing simple but for the life of me I haven't been able to figure it out.

Torc_TX

Posts : 3
Join date : 2013-11-04
Location : Fort Worth, TX

Back to top Go down

Re: Engine stall under load

Post  spence on Wed Oct 22, 2014 9:22 am

Is the idle control valve working properly? Do you have a scanner to check for codes / read iac count?
avatar
spence

Posts : 530
Join date : 2009-07-21
Age : 35
Location : St.Catharines, Ontario, Canada

Back to top Go down

Re: Engine stall under load

Post  zeusrotty on Wed Oct 22, 2014 3:30 pm

What throttle body do you have?

zeusrotty

Posts : 431
Join date : 2010-07-30

Back to top Go down

Re: Engine stall under load

Post  Torc_TX on Wed Oct 22, 2014 5:51 pm

Scanner doesn't read any codes.  I'm not sure about IAC count.  It's also bogging down on WOT.

Torc_TX

Posts : 3
Join date : 2013-11-04
Location : Fort Worth, TX

Back to top Go down

Re: Engine stall under load

Post  racertomtom on Wed Oct 22, 2014 6:46 pm

Hydraulic line crossed?

racertomtom

Posts : 134
Join date : 2014-07-04
Age : 57
Location : Southern Illinois

Back to top Go down

Re: Engine stall under load

Post  Lemming on Thu Oct 23, 2014 7:44 am

racertomtom wrote:Hydraulic line crossed?

Yes, it sounds like there's too much back pressure on the PS pump, which is causing the stall.
avatar
Lemming

Posts : 855
Join date : 2011-05-30
Location : B'ham

Back to top Go down

Re: Engine stall under load

Post  Torc_TX on Thu Oct 23, 2014 8:07 am

Thanks, let me try that this afternoon when I get off.

Torc_TX

Posts : 3
Join date : 2013-11-04
Location : Fort Worth, TX

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum