Mon Jul 08, 2013 3:56 pm by Admin

For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» 1986 944 na with turbo 5.3 for sale
Today at 6:33 am by Patb

» Simple Heater Valve Solution for Early Cars (And Late)
Yesterday at 6:35 pm by haroldk

» ecotec swap
Sat Mar 17, 2018 3:53 pm by Hotrodz of Dallas

» New 944 widebody & aero
Fri Mar 16, 2018 6:20 pm by scryfst

» Wilwood MC on it's side
Fri Mar 16, 2018 6:09 pm by scryfst

» V8 Conversion Parts
Tue Mar 13, 2018 11:15 pm by Chaxce

» This Hydroboost system is going to drive me nuts
Tue Mar 13, 2018 10:46 pm by Red944ls1

» Fuel pump options
Sun Mar 11, 2018 11:05 pm by V8it

» New convert under way
Sun Mar 11, 2018 9:56 pm by V8it

» Poly engine mounts melted
Sat Mar 10, 2018 12:11 pm by acorad

March 2018

Calendar Calendar

Log in

I forgot my password

Turbo radiator fan sensor

Go down

Turbo radiator fan sensor

Post  jpkinerk on Wed Feb 12, 2014 9:15 pm

So I'm using a turbo radiator in my swap and picked up a used fan sensor to plug the hole below the upper radiator inlet. It looked like it would screw right in, but it appears to be too small and the hole, upon further inspection, doesn't appear to have threads in it. My friend brought over another fan sensor to be sure I didn't have the wrong part, but we had the same issue as with the first sensor.

Anyone have any ideas? Thanks in advance.

Posts : 160
Join date : 2013-02-13

Back to top Go down

Re: Turbo radiator fan sensor

Post  Geoff Daniels on Thu Feb 13, 2014 12:02 pm

I am using my 951 radiator and the sensor should definitely thread in. Did you get your radiator from a reliable source. By the way, the factory sensor and wiring works fine for controlling the fans.

Geoff Daniels

Posts : 28
Join date : 2011-04-27
Location : Maryland

Back to top Go down

Back to top

Permissions in this forum:
You cannot reply to topics in this forum