HOW TO DO AN ADVANCED SEARCH.

Mon Jul 08, 2013 3:56 pm by Admin


For the benefit of 944Hybrids users there are two search functions available for you to use.
The purpose of this sticky is to explain the "Advanced Search" function because it is much more powerful and is the best choice when researching information.

When you log on to the site a list of options is shown in a line at the top of the page. One option is labelled "Search", use this option (NOT the search box lower down on the right).

After you click on the upper search option, a drop down box appears. At the bottom of this box is a radio button marked "Advanced …

Comments: 0

Latest topics
» 944 with LS3 Brake Fluid Fire Mistake
Yesterday at 9:31 pm by sharkey

» Transaxle rebuild
Yesterday at 9:24 pm by sharkey

» LS3 conversion
Yesterday at 9:19 pm by sharkey

» Noisy VSS and stalling???
Yesterday at 8:27 pm by matt889

» Hello, Gentlemen.
Yesterday at 7:43 pm by rawr

» alignment specs
Yesterday at 12:53 am by sharkey

» A/C parts used for the swap !
Thu Jul 19, 2018 8:04 pm by Rothaus

» Drive shaft too short to reach pilot bearning
Wed Jul 18, 2018 10:28 pm by spence

» 944 with LS3 bucking or jerking while cruising or low speed problem
Tue Jul 17, 2018 12:44 am by Porsche951toLS3

» 1987 944 Turbo --> LS
Mon Jul 16, 2018 6:52 pm by chrenan

July 2018
MonTueWedThuFriSatSun
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Calendar Calendar

Log in

I forgot my password


Instrument question

Go down

Instrument question

Post  fliermike45 on Fri Jun 07, 2013 9:20 am

My 88 944 Instrument cluster has a problem, Speedometer works OK but the odometer and trip do not work. Rev Counter does not work, what's common here??? Fuel/temp/oil and volts all work OK.
Everything did work OK at the completion of the swap.
Pressing tho odometer reset causes the odometer digits to twitch.

fliermike45

Posts : 778
Join date : 2009-09-19

Back to top Go down

Re: Instrument question

Post  Rich L. on Fri Jun 07, 2013 11:16 am

My odo and trip are the same. It's a common problem with the little plastic gears in there. I bought a replacement gear but have yet to take things apart and try to fix it.

[You must be registered and logged in to see this link.]

[You must be registered and logged in to see this link.]

Rich
avatar
Rich L.

Posts : 820
Join date : 2011-05-30
Location : Seattle

Back to top Go down

Re: Instrument question

Post  gdopnt on Fri Jun 07, 2013 6:42 pm

I replaced the gear in my 86. the hardest part was being careful with the old plastic parts. Clark's garage pretty much explains it as it happens. Make sure the reset pad goes back in the same spot. The reset button in vent hits a pad behind the vent and a push rod resets the odometer electrically. My gear was mush a hard plastic gear over time turns soft and the opposing gear eats it also you are not to reset the odometer unless you are stopped.


gdopnt

Posts : 126
Join date : 2012-11-12
Location : Rockford, Illinois

Back to top Go down

Odometer gear

Post  fliermike45 on Tue Jul 02, 2013 6:35 pm

I fixed my speedometer today and followed the Clarkes elect-09 instructions.
My gear was in two pieces and had gone very soft.

fliermike45

Posts : 778
Join date : 2009-09-19

Back to top Go down

Re: Instrument question

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum